summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptohash/cryptohash-0.9.1.ebuild')
-rw-r--r--dev-haskell/cryptohash/cryptohash-0.9.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild b/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild
deleted file mode 100644
index 708b5bbf8d17..000000000000
--- a/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.2.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="collection of crypto hashes, fast, pure and practical"
-HOMEPAGE="https://github.com/vincenthz/hs-cryptohash"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cryptoapi"
-
-RDEPEND="dev-haskell/byteable:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- cryptoapi? ( >=dev-haskell/cereal-0.2:=[profile?]
- >=dev-haskell/crypto-api-0.5:=[profile?]
- >=dev-haskell/tagged-0.1:=[profile?]
- )"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit
- >=dev-haskell/quickcheck-2
- >=dev-haskell/test-framework-0.3.3
- dev-haskell/test-framework-hunit
- >=dev-haskell/test-framework-quickcheck2-0.2.9
- )"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag cryptoapi cryptoapi)
-}