summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/diff/diff-0.4.1.ebuild')
-rw-r--r--dev-haskell/diff/diff-0.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/diff/diff-0.4.1.ebuild b/dev-haskell/diff/diff-0.4.1.ebuild
new file mode 100644
index 000000000000..6d276a997ec7
--- /dev/null
+++ b/dev-haskell/diff/diff-0.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_PN="Diff"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="O(ND) diff algorithm in haskell"
+HOMEPAGE="https://hackage.haskell.org/package/Diff"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ )
+"