summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/digest/digest-0.0.1.3.ebuild')
-rw-r--r--dev-haskell/digest/digest-0.0.1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-haskell/digest/digest-0.0.1.3.ebuild b/dev-haskell/digest/digest-0.0.1.3.ebuild
new file mode 100644
index 000000000000..a0b9dd81d18f
--- /dev/null
+++ b/dev-haskell/digest/digest-0.0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Various cryptographic hashes for bytestrings; CRC32 and Adler32 for now"
+HOMEPAGE="https://hackage.haskell.org/package/digest"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"