summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/distributive/distributive-0.3.2.ebuild')
-rw-r--r--dev-haskell/distributive/distributive-0.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/distributive/distributive-0.3.2.ebuild b/dev-haskell/distributive/distributive-0.3.2.ebuild
new file mode 100644
index 000000000000..d13b99c41700
--- /dev/null
+++ b/dev-haskell/distributive/distributive-0.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell 98 Distributive functors -- Dual to Traversable"
+HOMEPAGE="http://github.com/ekmett/distributive/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-werror"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-compat-0.1:=[profile?] <dev-haskell/transformers-compat-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-werror lib-werror)
+}