summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/doctest/doctest-0.22.0.ebuild')
-rw-r--r--dev-haskell/doctest/doctest-0.22.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/doctest/doctest-0.22.0.ebuild b/dev-haskell/doctest/doctest-0.22.0.ebuild
new file mode 100644
index 000000000000..dc7c9f3630e0
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.22.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/base-compat-0.7.0:=[profile?]
+ >=dev-haskell/code-page-0.1:=[profile?]
+ >=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?]
+ >=dev-lang/ghc-8.0:=[profile?] <dev-lang/ghc-9.7:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/hspec-2.3.0
+ >=dev-haskell/hspec-core-2.3.0
+ dev-haskell/hunit
+ dev-haskell/mockery
+ >=dev-haskell/quickcheck-2.13.1
+ dev-haskell/setenv
+ >=dev-haskell/silently-1.2.4
+ >=dev-haskell/stringbuilder-0.4 )
+"