summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/exceptions')
-rw-r--r--dev-haskell/exceptions/Manifest3
-rw-r--r--dev-haskell/exceptions/exceptions-0.3.3.ebuild30
-rw-r--r--dev-haskell/exceptions/exceptions-0.6.1.ebuild30
-rw-r--r--dev-haskell/exceptions/exceptions-0.8.0.2.ebuild37
-rw-r--r--dev-haskell/exceptions/metadata.xml11
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-haskell/exceptions/Manifest b/dev-haskell/exceptions/Manifest
new file mode 100644
index 000000000000..ad0694c2358c
--- /dev/null
+++ b/dev-haskell/exceptions/Manifest
@@ -0,0 +1,3 @@
+DIST exceptions-0.3.3.tar.gz 13036 SHA256 34f945d37d9958b8a35e88c5c9c309ff10da820ba0f85756eea64aaaf747cfbe SHA512 3264f78b950a3ea737f577e5ee406bddc1916bf93271ff6e78a477b1575bb105ce0c47324c4f56288a7ef6e7cba398dfb66ea66ee07baf5aaa17012cd6cc4da4 WHIRLPOOL 0347c5155be5ca2b7e9a1b1ddeb9ce54373e3860c7eba0cba7f7155be299f1b113b1793ade9251460b4e42967340a19aa6bf7d2f90520bcd6393535994666af2
+DIST exceptions-0.6.1.tar.gz 11392 SHA256 f56b3f97f5ad49c6e7efde386683ec52c8c4b853bbdda068690e913db52c5b26 SHA512 92413cfa9fccd877303ec4f100c4ac94d3e30df0563600733a940c3a3ee9d4e1e934bd6d09774faed684c8ea9821b8c44cf501cc44fe8c834dd19e2efbed5070 WHIRLPOOL 9b247d598c32dd301bb07d29c7e1558adc2348a66592f8b549bbfedc05fd24ced43dca05297ee43641b37a91bcb834c440883213eb0a08a0b84cd2f7bf1599a7
+DIST exceptions-0.8.0.2.tar.gz 12241 SHA256 070a3e0d1495243770fb3a629d5187ce898f069cb3621c5f7c610ae264982bf4 SHA512 8ed232f97f9d705f694aa9e0261c7920666cb0052d00370883b08fa6f61a97f8b17643512bdda5189760a51b42a9340e153521abafec20d42ffa193f3b0369b3 WHIRLPOOL e32d723c93829b5105429f70b08e35947a8b6f0e4a662bbebe48a062630c05ec71641fa2fdb34d7dc56c2271e35e9fecca0c62f573cd2f2ced270d3d74bc9de3
diff --git a/dev-haskell/exceptions/exceptions-0.3.3.ebuild b/dev-haskell/exceptions/exceptions-0.3.3.ebuild
new file mode 100644
index 000000000000..b106c7328e3f
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="http://github.com/ekmett/exceptions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.7
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
diff --git a/dev-haskell/exceptions/exceptions-0.6.1.ebuild b/dev-haskell/exceptions/exceptions-0.6.1.ebuild
new file mode 100644
index 000000000000..982762578ac3
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="http://github.com/ekmett/exceptions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.8
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
diff --git a/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild b/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild
new file mode 100644
index 000000000000..8b48cf9806fb
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="http://github.com/ekmett/exceptions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.5:2
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.5 && < 2.8' 'QuickCheck >= 2.5'
+}
diff --git a/dev-haskell/exceptions/metadata.xml b/dev-haskell/exceptions/metadata.xml
new file mode 100644
index 000000000000..b7da76b43080
--- /dev/null
+++ b/dev-haskell/exceptions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Extensible optionally-pure exceptions
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ekmett/exceptions</remote-id>
+ </upstream>
+</pkgmetadata>