summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/feed')
-rw-r--r--dev-haskell/feed/Manifest3
-rw-r--r--dev-haskell/feed/feed-1.3.2.1-r2.ebuild53
-rw-r--r--dev-haskell/feed/feed-1.3.2.1.ebuild (renamed from dev-haskell/feed/feed-1.3.0.1.ebuild)35
-rw-r--r--dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch18
-rw-r--r--dev-haskell/feed/metadata.xml3
5 files changed, 91 insertions, 21 deletions
diff --git a/dev-haskell/feed/Manifest b/dev-haskell/feed/Manifest
index 29c505411fc1..566241aa016a 100644
--- a/dev-haskell/feed/Manifest
+++ b/dev-haskell/feed/Manifest
@@ -1 +1,2 @@
-DIST feed-1.3.0.1.tar.gz 107230 BLAKE2B 5ed36f28c63e2af4669a37cac0715891b96d37570dfa99404df5764ad1e5b4e512d3d1a54e263c838875cc4a29ce00b3a022b3a2647983cbda4011ba5accd855 SHA512 73662018affac036bcd3c48a8a5b6fcd4e752231d805c12e977c6097a47691c2eca07eb8d6e6840a592bf35892b4b4ec44fb1f73f8a14ecb47fc6904b406f767
+DIST feed-1.3.2.1-rev2.cabal 4607 BLAKE2B fb55afd490af9997dbb17b9b38ef7cdd6d375b62cafd96800af593b6157cc39c7e585ef8c5543151608d22a4332e7c4530e223fc745b60863276990a508c83f2 SHA512 76a02c57cbbbf9bbd4bedef063eb636a029ba32dbff4c580561f6472d6d54d3caf1afe7b98fb2d4423ac9352160cd25b7b1ad965c51f5280ab786b9fc9a4bddb
+DIST feed-1.3.2.1.tar.gz 107015 BLAKE2B 4a40441b17f50b9e7d43aee629fa0bc44f5b5cd1ca6281f3f5a8930b9cc5c2acdbdff05e9db4cc96c0e40681ecb15896655d8bbc708dc0bc4e3734b6e9f563bd SHA512 2175201ff9eaab5732e1c4e8dda6a35e8fa0dea5c58cd379348c97cd61a5eaf76e88f8d58d22df0a4b16681017e7ad01657ad60a63d90dab88df3b644ccb1ea0
diff --git a/dev-haskell/feed/feed-1.3.2.1-r2.ebuild b/dev-haskell/feed/feed-1.3.2.1-r2.ebuild
new file mode 100644
index 000000000000..35f9c5f9796d
--- /dev/null
+++ b/dev-haskell/feed/feed-1.3.2.1-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/haskell-party/feed"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.2.1-disable-doctest.patch" )
+
+RDEPEND="
+ >=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.14
+ =dev-haskell/old-locale-1.0*:=[profile?]
+ >=dev-haskell/old-time-1:=[profile?] <dev-haskell/old-time-1.2
+ =dev-haskell/safe-0.3*:=[profile?]
+ =dev-haskell/time-locale-compat-0.1*:=[profile?]
+ <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-conduit-1.3:=[profile?] <dev-haskell/xml-conduit-1.10
+ >=dev-haskell/xml-types-0.3.6:=[profile?] <dev-haskell/xml-types-0.4
+ || (
+ <dev-haskell/text-1.3
+ =dev-haskell/text-2.0*
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/text
+ dev-haskell/doctest
+ dev-haskell/doctest-driver-gen
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ dev-haskell/syb
+ =dev-haskell/test-framework-0.8*
+ =dev-haskell/test-framework-hunit-0.3*
+ )
+"
+BDEPEND="test? (
+ dev-haskell/doctest-driver-gen[executable(+)]
+ dev-haskell/markdown-unlit[executable(+)]
+)"
diff --git a/dev-haskell/feed/feed-1.3.0.1.ebuild b/dev-haskell/feed/feed-1.3.2.1.ebuild
index 909b96ff32b8..f4ae6cc810f3 100644
--- a/dev-haskell/feed/feed-1.3.0.1.ebuild
+++ b/dev-haskell/feed/feed-1.3.2.1.ebuild
@@ -1,42 +1,39 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.4.9999
+# ebuild generated by hackport 0.7.1.1.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # markdown-unlit fals to generate a test: "test-suite"
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
-HOMEPAGE="https://github.com/bergmark/feed"
+HOMEPAGE="https://github.com/haskell-party/feed"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-RESTRICT=test # ghc: could not execute: markdown-unlit
+PATCHES=( "${FILESDIR}/${PN}-1.3.2.1-disable-doctest.patch" )
-RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.12:=[profile?]
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.13:=[profile?]
>=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
>=dev-haskell/old-time-1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
>=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
- <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
<dev-haskell/utf8-string-1.1:=[profile?]
>=dev-haskell/xml-conduit-1.3:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
>=dev-haskell/xml-types-0.3.6:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
- >=dev-lang/ghc-7.4.1:=
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/doctest
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/markdown-unlit-0.4 <dev-haskell/markdown-unlit-0.6
+ dev-haskell/syb
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >= 4 && < 4.14' 'base >= 4'
-}
diff --git a/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch b/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch
new file mode 100644
index 000000000000..01ebc6537499
--- /dev/null
+++ b/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch
@@ -0,0 +1,18 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+
+These doctests are difficult to run successfully and aren't worth the effort.
+
+diff -urN feed-1.3.2.1/feed.cabal feed-1.3.2.1-r1/feed.cabal
+--- feed-1.3.2.1/feed.cabal 2022-03-28 20:36:31.561223247 -0600
++++ feed-1.3.2.1-r1/feed.cabal 2022-03-28 21:05:49.501202376 -0600
+@@ -153,8 +153,7 @@
+ main-is: doctest-driver.hs
+ type: exitcode-stdio-1.0
+ default-language: Haskell2010
+- if impl(ghc < 8)
+- buildable: False
++ buildable: False
+ build-depends:
+ base >= 4.6
+ , doctest
diff --git a/dev-haskell/feed/metadata.xml b/dev-haskell/feed/metadata.xml
index e7fd109bb29d..ef8599691279 100644
--- a/dev-haskell/feed/metadata.xml
+++ b/dev-haskell/feed/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
- <remote-id type="github">sof/feed</remote-id>
+ <remote-id type="hackage">feed</remote-id>
+ <remote-id type="github">haskell-party/feed</remote-id>
</upstream>
</pkgmetadata>