summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/filestore/filestore-0.6.1.ebuild')
-rw-r--r--dev-haskell/filestore/filestore-0.6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-haskell/filestore/filestore-0.6.1.ebuild b/dev-haskell/filestore/filestore-0.6.1.ebuild
index 944819418c1c..61f23d46549a 100644
--- a/dev-haskell/filestore/filestore-0.6.1.ebuild
+++ b/dev-haskell/filestore/filestore-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,14 @@ DEPEND+="
)
"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
+
+ cabal_chdeps \
+ 'time >= 1.1 && < 1.6' 'time >= 1.1' \
+ 'process >= 1.0 && < 1.3' 'process >= 1.0'
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag maxcount maxcount)