summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/foundation')
-rw-r--r--dev-haskell/foundation/Manifest3
-rw-r--r--dev-haskell/foundation/foundation-0.0.26.1.ebuild (renamed from dev-haskell/foundation/foundation-0.0.25.ebuild)16
-rw-r--r--dev-haskell/foundation/foundation-0.0.30.ebuild35
-rw-r--r--dev-haskell/foundation/metadata.xml25
4 files changed, 50 insertions, 29 deletions
diff --git a/dev-haskell/foundation/Manifest b/dev-haskell/foundation/Manifest
index a0dae253bcc2..f2b9f641976b 100644
--- a/dev-haskell/foundation/Manifest
+++ b/dev-haskell/foundation/Manifest
@@ -1 +1,2 @@
-DIST foundation-0.0.25.tar.gz 120472 BLAKE2B 2cff11363840b0b338b57d38438a13211e41a8e9bc6c359552dfb1854c9277c3228aac88b4a7930031fab75f78574cbe1cac6d5c87936f9b179e5c2277c00ff5 SHA512 7335795a1cdf2975d6e9471c5b469d99cc6d224d2da66838d830593a5abda73675920acb2dc823a6b92f2141dc2364c8fd5ad53d7e8aecd8df00e6998683be60
+DIST foundation-0.0.26.1.tar.gz 120487 BLAKE2B 9ded2f69712de5f3af7fd6a2457defaaf7643c8eee51ad27c863ba0f00a39d05c768a3ae03cb9b8401c63e545161f194237e6bd346e6e6e8858ac7d8a33c6cc1 SHA512 56285e445dbf58204fffb3824a2f6144c3ef8eeb1630a5f5e9a658bc216a9bbb4db6f215e1e9b11bb516a389e23a9fc3275242d060b42db6b82b6a449224988a
+DIST foundation-0.0.30.tar.gz 120423 BLAKE2B bc9f63b3b25d01eee2b3ce3f648987d8f040385759638103574821ffc0d124455f574755105e54af2f338c036edd50c36101bec8f0cb9afaaf2086bdb3365cf9 SHA512 5b7a193a03f6f86f125a95363705c760f3ce8686720aa91e815daf131b42cb84a8fd39d448f4b2e803654e1e4764fdfea28918c4558c5f87451aa7c05714efda
diff --git a/dev-haskell/foundation/foundation-0.0.25.ebuild b/dev-haskell/foundation/foundation-0.0.26.1.ebuild
index 1f75b31ea271..e5dc055fb793 100644
--- a/dev-haskell/foundation/foundation-0.0.25.ebuild
+++ b/dev-haskell/foundation/foundation-0.0.26.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.1.9999
+# ebuild generated by hackport 0.6.7.9999
#hackport: flags: +doctest,-minimal-deps,-bench-all,-bounds-check,-linktest
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
@@ -15,16 +15,16 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="experimental"
-RESTRICT="test" # fails to doctest
+RESTRICT=test # hangs indefinitely
-RDEPEND="~dev-haskell/basement-0.0.11:=[profile?]
- >=dev-lang/ghc-8.0.1:=
+RDEPEND="~dev-haskell/basement-0.0.12:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.0.0
+ >=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/basement
>=dev-haskell/doctest-0.9 )
"
diff --git a/dev-haskell/foundation/foundation-0.0.30.ebuild b/dev-haskell/foundation/foundation-0.0.30.ebuild
new file mode 100644
index 000000000000..34c119a9149c
--- /dev/null
+++ b/dev-haskell/foundation/foundation-0.0.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -doctest,-minimal-deps,-bench-all,-bounds-check,-linktest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Alternative prelude with batteries and no dependencies"
+HOMEPAGE="https://github.com/haskell-foundation/foundation"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="experimental"
+
+RDEPEND=">=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ ~dev-haskell/basement-0.0.16
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bench-all \
+ --flag=-bounds-check \
+ --flag=-doctest \
+ $(cabal_flag experimental experimental) \
+ --flag=-linktest \
+ --flag=-minimal-deps
+}
diff --git a/dev-haskell/foundation/metadata.xml b/dev-haskell/foundation/metadata.xml
index 0150690448f8..78fbc1c25ade 100644
--- a/dev-haskell/foundation/metadata.xml
+++ b/dev-haskell/foundation/metadata.xml
@@ -6,25 +6,10 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="experimental">enable building experimental features, known as highly unstable or without good support cross-platform</flag>
+ <flag name="experimental">Enable building experimental features, known as highly unstable or without good support cross-platform</flag>
</use>
- <longdescription>
- A custom prelude with no dependencies apart from base.
-
- This package has the following goals:
-
- * provide a base like sets of modules that provide a consistent set of features and bugfixes across multiple versions of GHC (unlike base).
-
- * provide a better and more efficient prelude than base's prelude.
-
- * be self-sufficient: no external dependencies apart from base.
-
- * provide better data-types: packed unicode string by default, arrays.
-
- * Better numerical classes that better represent mathematical thing (No more all-in-one Num).
-
- * Better I/O system with less Lazy IO
-
- * Usual partial functions distinguished through type system
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">foundation</remote-id>
+ <remote-id type="github">haskell-foundation/foundation</remote-id>
+ </upstream>
</pkgmetadata>