summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild')
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
index 2eaacd92bdb9..c1b92212a47b 100644
--- a/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.2.9999
@@ -10,29 +10,31 @@ CABAL_FEATURES="lib profile"
inherit haskell-cabal
DESCRIPTION="Knowledge of GHC's installation directories"
-HOMEPAGE="http://hackage.haskell.org/package/ghc-paths"
+HOMEPAGE="https://hackage.haskell.org/package/ghc-paths"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND=">=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6 <dev-haskell/cabal-3.3
+ >=dev-haskell/cabal-1.6 <dev-haskell/cabal-3.7
"
+# https://github.com/simonmar/ghc-paths/pull/26
+CABAL_CHDEPS=(
+ 'Cabal >= 1.6 && <3.1' 'Cabal >= 1.6 && <3.7'
+)
+
src_prepare() {
- default
+ haskell-cabal_src_prepare
# ghc-patch it has awfully unportable (across cabal versions) ghc detection code
# but in gentoo we install it to fixed patch, so remove Setup.hs detection code
cabal-mksetup
- cabal_chdeps \
- 'Cabal >= 1.6 && <3.1' 'Cabal >= 1.6 && <3.3'
-
# and use gentoo's hardcoded one:
# a few things we need to replace, and example values
# GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010