summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/git-lfs/git-lfs-1.2.0-r1.ebuild')
-rw-r--r--dev-haskell/git-lfs/git-lfs-1.2.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/git-lfs/git-lfs-1.2.0-r1.ebuild b/dev-haskell/git-lfs/git-lfs-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..70a2acec2e8f
--- /dev/null
+++ b/dev-haskell/git-lfs/git-lfs-1.2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="git-lfs protocol"
+HOMEPAGE="https://hackage.haskell.org/package/git-lfs"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'aeson >= 1.3 && < 2.1' 'aeson >= 1.3'
+)
+
+RDEPEND="
+ >=dev-haskell/aeson-1.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/http-client-0.5:=[profile?] <dev-haskell/http-client-0.8:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.8:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"