summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/glib')
-rw-r--r--dev-haskell/glib/glib-0.12.5.4.ebuild6
-rw-r--r--dev-haskell/glib/glib-0.13.2.2.ebuild6
-rw-r--r--dev-haskell/glib/glib-0.13.4.1.ebuild6
-rw-r--r--dev-haskell/glib/metadata.xml2
4 files changed, 10 insertions, 10 deletions
diff --git a/dev-haskell/glib/glib-0.12.5.4.ebuild b/dev-haskell/glib/glib-0.12.5.4.ebuild
index 4e4b8a2cba01..ce89149d644c 100644
--- a/dev-haskell/glib/glib-0.12.5.4.ebuild
+++ b/dev-haskell/glib/glib-0.12.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="+closure_signals"
+IUSE="+closure-signals"
RDEPEND=">=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
>=dev-lang/ghc-7.4.1:=
@@ -29,5 +29,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag closure_signals closure_signals)
+ $(cabal_flag closure-signals closure_signals)
}
diff --git a/dev-haskell/glib/glib-0.13.2.2.ebuild b/dev-haskell/glib/glib-0.13.2.2.ebuild
index eb6d807807d7..3980bd8dfe31 100644
--- a/dev-haskell/glib/glib-0.13.2.2.ebuild
+++ b/dev-haskell/glib/glib-0.13.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="+closure_signals"
+IUSE="+closure-signals"
RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
@@ -30,5 +30,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag closure_signals closure_signals)
+ $(cabal_flag closure-signals closure_signals)
}
diff --git a/dev-haskell/glib/glib-0.13.4.1.ebuild b/dev-haskell/glib/glib-0.13.4.1.ebuild
index d278d4cb7089..a0ec5d677531 100644
--- a/dev-haskell/glib/glib-0.13.4.1.ebuild
+++ b/dev-haskell/glib/glib-0.13.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="+closure_signals"
+IUSE="+closure-signals"
RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
@@ -30,5 +30,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag closure_signals closure_signals)
+ $(cabal_flag closure-signals closure_signals)
}
diff --git a/dev-haskell/glib/metadata.xml b/dev-haskell/glib/metadata.xml
index e57b11cbbed2..bf0f78078605 100644
--- a/dev-haskell/glib/metadata.xml
+++ b/dev-haskell/glib/metadata.xml
@@ -12,6 +12,6 @@
wrap libraries that are themselves based on GLib.
</longdescription>
<use>
- <flag name="closure_signals">Use the the GClosure-based signals implementation.</flag>
+ <flag name="closure-signals">Use the the GClosure-based signals implementation.</flag>
</use>
</pkgmetadata>