summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild')
-rw-r--r--dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild b/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild
deleted file mode 100644
index 2c6a4be4ebc2..000000000000
--- a/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.5.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Hackage security library"
-HOMEPAGE="https://github.com/haskell/hackage-security"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+network-uri"
-
-RESTRICT=test # QC-2.10 finds counterexamples
-
-RDEPEND=">=dev-haskell/base16-bytestring-0.1.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
- >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
- >=dev-haskell/cabal-1.14:=[profile?]
- >=dev-haskell/cryptohash-sha256-0.11:=[profile?] <dev-haskell/cryptohash-sha256-0.12:=[profile?]
- >=dev-haskell/ed25519-0.0:=[profile?] <dev-haskell/ed25519-0.1:=[profile?]
- >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
- >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
- >=dev-lang/ghc-7.10.1:=
- >=dev-haskell/old-locale-1.0:=[profile?]
- network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
- >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
- !network-uri? ( >=dev-haskell/network-2.5:=[profile?] <dev-haskell/network-2.6:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- test? ( >=dev-haskell/quickcheck-2.9
- >=dev-haskell/tasty-1.0
- >=dev-haskell/tasty-hunit-0.10
- >=dev-haskell/tasty-quickcheck-0.10
- >=dev-haskell/temporary-1.2
- !network-uri? ( dev-haskell/network-uri ) )
-"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-8.8.patch)
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >= 4.5 && < 4.12' 'base >= 4.5' \
- 'tasty == 1.0.*' 'tasty >= 1.0' \
- 'tasty-hunit == 0.10.*' 'tasty-hunit >= 0.10' \
- 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10' \
- 'QuickCheck == 2.9.*' 'QuickCheck >= 2.9' \
- 'temporary == 1.2.*' 'temporary >= 1.2' \
- 'network >= 2.6 && < 2.7' 'network >= 2.6' \
- 'Cabal >= 1.14 && < 2.4' 'Cabal >= 1.14' \
- 'containers >= 0.4 && < 0.6' 'containers >= 0.4' \
- 'time >= 1.2 && < 1.9' 'time >= 1.2'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag network-uri use-network-uri)
-}