summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/happy')
-rw-r--r--dev-haskell/happy/Manifest1
-rw-r--r--dev-haskell/happy/happy-1.19.12.ebuild11
-rw-r--r--dev-haskell/happy/happy-1.20.1.1.ebuild69
3 files changed, 70 insertions, 11 deletions
diff --git a/dev-haskell/happy/Manifest b/dev-haskell/happy/Manifest
index 9258d5307181..aaa3de4cec94 100644
--- a/dev-haskell/happy/Manifest
+++ b/dev-haskell/happy/Manifest
@@ -1 +1,2 @@
DIST happy-1.19.12.tar.gz 183254 BLAKE2B 17b0d30f4aaf194a0e36c06bd6349665c704b5ab61dce16cae47f0ca6bfef0a0e2d4bbf3456f47cebf0f71f1a0b4a59ff6b581cb4ff76a26d82573eb0e7b056a SHA512 20f36b17adf7330852fd4c05335adbf31e6f19907b4ec247c85a40ee1f8496c6dc432055026696906b149cec7f982b88c9a2eeedf14a11d34b1f6f73272e5208
+DIST happy-1.20.1.1.tar.gz 183409 BLAKE2B b9bb9da227b21e6a63a9649454745f32b6f9fb2c33132da60595ab1bbca0e6659a6941ec89ed0705f9c5052dfc1dc076888c0b309d797f699a1d398e04d5913a SHA512 a2ff6a1778884de22f4900a22b8a451ed5dc8a8e66020ce9e186a03068257748a3810c63b56f1efa0b646d99fe637f87178983f387d4c49bc33b82613877ec48
diff --git a/dev-haskell/happy/happy-1.19.12.ebuild b/dev-haskell/happy/happy-1.19.12.ebuild
index 46639787fa6a..6990fb9bf15d 100644
--- a/dev-haskell/happy/happy-1.19.12.ebuild
+++ b/dev-haskell/happy/happy-1.19.12.ebuild
@@ -18,19 +18,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="doc"
-# Re: LLVM blocker - ghc-9.0.2 generates IR that crashes LLVM opt
-# for two test cases. Unsure yet if this is a bug in the GHC LLVM
-# backend or in LLVM itself. Tracked in
-# https://github.com/llvm/llvm-project/issues/57393
-#
-# Must be in RDEPEND or pkgcheck complains about MisplaceWeakBlocker.
-# Although in theory it's possible to enable USE=llvm on an arch with
-# native codegen, there is no reason to do so, so in practice this should
-# block USE=test exclusively on arches that support registerised GHC
-# through the LLVM backend only.
RDEPEND=">=dev-haskell/mtl-2.2.1:=
>=dev-lang/ghc-7.4.1:=
- test? ( !dev-lang/ghc[llvm(-)] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
diff --git a/dev-haskell/happy/happy-1.20.1.1.ebuild b/dev-haskell/happy/happy-1.20.1.1.ebuild
new file mode 100644
index 000000000000..6fca2d8dd8a4
--- /dev/null
+++ b/dev-haskell/happy/happy-1.20.1.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +small_base
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="https://www.haskell.org/happy/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-haskell/mtl-2.2.1:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ default
+
+ if use doc; then
+ cd doc || die
+ eautoconf
+ fi
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure \
+ --with-happy=false\
+ --flag=small_base
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/happy/.
+ doman doc/happy.1
+ fi
+}