summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashtables/hashtables-1.1.2.1.ebuild')
-rw-r--r--dev-haskell/hashtables/hashtables-1.1.2.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild b/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
deleted file mode 100644
index c9196569efdb..000000000000
--- a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Mutable hash tables in the ST monad"
-HOMEPAGE="https://github.com/gregorycollins/hashtables"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bounds-checking portable cpu_flags_x86_sse4_1 +unsafe-tricks"
-
-RDEPEND="dev-haskell/primitive:=[profile?]
- >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bounds-checking bounds-checking) \
- $(cabal_flag portable portable) \
- $(cabal_flag cpu_flags_x86_sse4_1 sse41) \
- $(cabal_flag unsafe-tricks unsafe-tricks)
-}