summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild')
-rw-r--r--dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild b/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..e3c2e948c9c5
--- /dev/null
+++ b/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -examples
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+
+DESCRIPTION="A command-line interface for user input, written in Haskell"
+HOMEPAGE="https://github.com/judah/haskeline"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+terminfo"
+
+RESTRICT=test # test requires example executable which does not work correctly
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-examples \
+ $(cabal_flag terminfo terminfo)
+}
+
+CABAL_CORE_LIB_GHC_PV="8.10.6 8.10.7 9.0.2 9.2.4 9.2.5 9.2.6 9.2.7 9.2.8 9.4.4 9.4.5"