summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haskell-src-exts/haskell-src-exts-1.13.5.ebuild')
-rw-r--r--dev-haskell/haskell-src-exts/haskell-src-exts-1.13.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.5.ebuild b/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.5.ebuild
new file mode 100644
index 000000000000..b83cdce94549
--- /dev/null
+++ b/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer"
+HOMEPAGE="http://code.haskell.org/haskell-src-exts"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cpphs-1.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy"
+
+src_prepare() {
+ # test suite is broken, expects the package to be already installed.
+ # this new Setup.hs will use the package inplice for tests
+ cp "${FILESDIR}/haskell-src-exts-1.10.2-Setup.hs" "${S}/Setup.hs" \
+ || die "Could not cp Setup.hs for tests"
+
+ # remove broken tests. they will fail if you expect them to pass, and pass
+ # if you expect them to fail...
+ rm "${S}/Test/examples/Unicode"{.hs,Syntax.hs} \
+ || die "Could not rm broken tests"
+}