summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild
new file mode 100644
index 000000000000..0072be8a8d5a
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+#hackport: flags: -buildtests,+mintime15,+splitbase
+
+CABAL_PN="HDBC-postgresql"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+# error: Connection.hsc:34:10: fatal error: pg_config.h: No such file or directory
+RESTRICT="test" # Missing files
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-postgresql"
+
+LICENSE="BSD"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/hdbc-2.2.0:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildtests \
+ --flag=mintime15 \
+ --flag=splitbase
+}