summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hscolour/hscolour-1.19.ebuild')
-rw-r--r--dev-haskell/hscolour/hscolour-1.19.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/hscolour/hscolour-1.19.ebuild b/dev-haskell/hscolour/hscolour-1.19.ebuild
new file mode 100644
index 000000000000..7543a501c03d
--- /dev/null
+++ b/dev-haskell/hscolour/hscolour-1.19.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock"
+inherit base haskell-cabal
+
+DESCRIPTION="Colourise Haskell code"
+HOMEPAGE="http://code.haskell.org/~malcolm/hscolour/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+PATCHES=("${FILESDIR}/${PN}-1.19-ghc-7.5.patch")
+
+src_install() {
+ cabal_src_install
+ if use doc; then
+ dohtml hscolour.css
+ fi
+}