summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hslua-objectorientation')
-rw-r--r--dev-haskell/hslua-objectorientation/Manifest2
-rw-r--r--dev-haskell/hslua-objectorientation/hslua-objectorientation-2.2.0.ebuild32
-rw-r--r--dev-haskell/hslua-objectorientation/hslua-objectorientation-2.3.0.ebuild33
-rw-r--r--dev-haskell/hslua-objectorientation/metadata.xml12
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/hslua-objectorientation/Manifest b/dev-haskell/hslua-objectorientation/Manifest
new file mode 100644
index 000000000000..b8caecdf626f
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/Manifest
@@ -0,0 +1,2 @@
+DIST hslua-objectorientation-2.2.0.tar.gz 15240 BLAKE2B 741298dd4d47b5b0bc4da565f9bae1004f13fccb4cb617ad1603821df884604a12f481626af9314f84f781a48bff836367d7fb71ce0ca5e2d3d8058c5899b394 SHA512 c40f0526264db229093f39deb9e77a44e575e6ebf97f257ff063b61279cd47aeecda4204db2ebc686b3e8ac467e2a0f4887608a54386f4afca2d47b469ee6107
+DIST hslua-objectorientation-2.3.0.tar.gz 16615 BLAKE2B 7760d09d30631bdac2255c33a12a005b134b7643d71092076d7a8142c78bb9ae9b54cb0f727746df837cf5a2661c1442edc97560a0fe839e1bd25fe0214ac413 SHA512 648dd92b7b51d8edfc8fcf455e3ae87afc828aeb4f5e54cb7d4f23d0e12173369ecac6ac44a79ddb474e723d1b007615492018d375aa7a4d58abbd13752a84e3
diff --git a/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.2.0.ebuild b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.2.0.ebuild
new file mode 100644
index 000000000000..380a7df3bd7a
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Object orientation tools for HsLua"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/hslua-core-2.2:=[profile?] <dev-haskell/hslua-core-2.3:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.2:=[profile?] <dev-haskell/hslua-marshalling-2.3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hslua-1.0
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
diff --git a/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.3.0.ebuild b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.3.0.ebuild
new file mode 100644
index 000000000000..6c61223c4187
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Object orientation tools for HsLua"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/hslua-core-2.2.1:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.2.1:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/hslua-typing-0.1:=[profile?] <dev-haskell/hslua-typing-0.2:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hslua-1.0
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
diff --git a/dev-haskell/hslua-objectorientation/metadata.xml b/dev-haskell/hslua-objectorientation/metadata.xml
new file mode 100644
index 000000000000..c43dd0fe0783
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="hackage">hslua-objectorientation</remote-id>
+ <remote-id type="github">hslua/hslua</remote-id>
+ </upstream>
+</pkgmetadata>