summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild')
-rw-r--r--dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild b/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild
new file mode 100644
index 000000000000..25501539d61c
--- /dev/null
+++ b/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Isocline-based Lua REPL"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/hslua-core-2.3.1:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/isocline-1.0:=[profile?] <dev-haskell/isocline-1.1:=[profile?]
+ >=dev-haskell/lua-2.3:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}