summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hslua-typing/hslua-typing-0.1.0.ebuild')
-rw-r--r--dev-haskell/hslua-typing/hslua-typing-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/hslua-typing/hslua-typing-0.1.0.ebuild b/dev-haskell/hslua-typing/hslua-typing-0.1.0.ebuild
new file mode 100644
index 000000000000..2d60654a9256
--- /dev/null
+++ b/dev-haskell/hslua-typing/hslua-typing-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type specifiers for Lua"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/hslua-core-2.3:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.3:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0 <dev-haskell/lua-arbitrary-1.1
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"