summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hslua/hslua-1.1.2.ebuild')
-rw-r--r--dev-haskell/hslua/hslua-1.1.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-haskell/hslua/hslua-1.1.2.ebuild b/dev-haskell/hslua/hslua-1.1.2.ebuild
deleted file mode 100644
index 829469faf3e7..000000000000
--- a/dev-haskell/hslua/hslua-1.1.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6
-#hackport: flags: -allow-unsafe-gc,-apicheck,-export-dynamic,-lua501,-lua502,-lua_32bits,-system-lua,-pkg-config
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A Lua language interpreter embedding in Haskell"
-HOMEPAGE="https://hslua.github.io/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="hardcode-reg-keys"
-
-RDEPEND=">=dev-haskell/base-compat-0.10:=[profile?]
- >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
- >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-5:=[profile?]
- >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
- >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.10.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- test? ( >=dev-haskell/quickcheck-2.7
- >=dev-haskell/quickcheck-instances-0.3
- >=dev-haskell/tasty-0.11
- >=dev-haskell/tasty-hunit-0.9
- >=dev-haskell/tasty-quickcheck-0.8 )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-allow-unsafe-gc \
- --flag=-apicheck \
- --flag=-export-dynamic \
- $(cabal_flag hardcode-reg-keys hardcode-reg-keys) \
- --flag=-lua501 \
- --flag=-lua502 \
- --flag=-lua_32bits \
- --flag=-pkg-config \
- --flag=-system-lua
-}