summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hspec/hspec-2.2.1.ebuild')
-rw-r--r--dev-haskell/hspec/hspec-2.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hspec/hspec-2.2.1.ebuild b/dev-haskell/hspec/hspec-2.2.1.ebuild
new file mode 100644
index 000000000000..8e0cd6f97aae
--- /dev/null
+++ b/dev-haskell/hspec/hspec-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Testing Framework for Haskell"
+HOMEPAGE="http://hspec.github.io/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # has circular dependency
+
+RDEPEND="~dev-haskell/hspec-core-2.2.1:=[profile?]
+ ~dev-haskell/hspec-discover-2.2.1:=[profile?]
+ >=dev-haskell/hspec-expectations-0.7.2:=[profile?] <dev-haskell/hspec-expectations-0.7.3:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/quickcheck-2.5.1:2=[profile?]
+ >=dev-haskell/transformers-0.2.2.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hspec-core
+ >=dev-haskell/hspec-meta-2.2.0
+ dev-haskell/stringbuilder )
+"