summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild')
-rw-r--r--dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
index 756bb6481b97..12061ee0f047 100644
--- a/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
+++ b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=4
+CABAL_PN="HsYAML"
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
-MY_PN="HsYAML"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pure Haskell YAML 1.2 parser"
+DESCRIPTION="Pure Haskell YAML 1.2 processor"
HOMEPAGE="https://github.com/hvr/HsYAML"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/fail-4.9.0.0:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
@@ -27,20 +27,11 @@ RDEPEND=">=dev-haskell/fail-4.9.0.0:=[profile?] <dev-haskell/fail-4.10:=[profile
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.14
- test? ( >=dev-haskell/quickcheck-2.13:2=
+ test? ( >=dev-haskell/quickcheck-2.13:=
>=dev-haskell/tasty-1.2:=
>=dev-haskell/tasty-quickcheck-0.10:= )
"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >=4.5 && <4.14' 'base >=4.5' \
- 'containers >=0.4.2 && <0.7' 'containers >=0.4.2' \
- 'QuickCheck == 2.13.*' 'QuickCheck >= 2.13' \
- 'tasty == 1.2.*' 'tasty >= 1.2' \
- 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10'
+src_configure() {
+ haskell-cabal_src_configure --flag=-exe
}