summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-api-data/http-api-data-0.4.1.1.ebuild')
-rw-r--r--dev-haskell/http-api-data/http-api-data-0.4.1.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-haskell/http-api-data/http-api-data-0.4.1.1.ebuild b/dev-haskell/http-api-data/http-api-data-0.4.1.1.ebuild
deleted file mode 100644
index f64232f9c25c..000000000000
--- a/dev-haskell/http-api-data/http-api-data-0.4.1.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Converting to/from HTTP API data like URL pieces, headers and query parameters"
-HOMEPAGE="https://github.com/fizruk/http-api-data"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/attoparsec-0.13.2.2:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
- >=dev-haskell/attoparsec-iso8601-1.0.1.0:=[profile?] <dev-haskell/attoparsec-iso8601-1.1:=[profile?]
- >=dev-haskell/base-compat-0.10.5:=[profile?] <dev-haskell/base-compat-0.12:=[profile?]
- >=dev-haskell/cookie-0.4.3:=[profile?] <dev-haskell/cookie-0.5:=[profile?]
- >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
- >=dev-haskell/http-types-0.12.3:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
- >=dev-haskell/nats-1.1.2:=[profile?] <dev-haskell/nats-1.2:=[profile?]
- >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
- >=dev-haskell/tagged-0.8.5:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-haskell/time-compat-1.9.2:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
- >=dev-haskell/unordered-containers-0.2.10.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
- >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
- >=dev-haskell/void-0.7.3:=[profile?] <dev-haskell/void-0.8:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/hspec-2.7.1 <dev-haskell/hspec-2.8
- >=dev-haskell/hunit-1.6.0.0 <dev-haskell/hunit-1.7
- >=dev-haskell/quickcheck-2.13.1 <dev-haskell/quickcheck-2.14
- >=dev-haskell/quickcheck-instances-0.3.21 <dev-haskell/quickcheck-instances-0.4 )
-"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >= 4.7 && < 4.14' 'base >= 4.7'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-use-text-show
-}