summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-date/http-date-0.0.11.ebuild')
-rw-r--r--dev-haskell/http-date/http-date-0.0.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/http-date/http-date-0.0.11.ebuild b/dev-haskell/http-date/http-date-0.0.11.ebuild
new file mode 100644
index 000000000000..36ad83942cf4
--- /dev/null
+++ b/dev-haskell/http-date/http-date-0.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP Date parser/formatter"
+HOMEPAGE="https://hackage.haskell.org/package/http-date"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.8.0.2
+
+RDEPEND="dev-haskell/attoparsec:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/old-locale )
+"