summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild')
-rw-r--r--dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
new file mode 100644
index 000000000000..88c02ec0b857
--- /dev/null
+++ b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -more-tests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: compiler-dependent
+inherit haskell-cabal
+
+DESCRIPTION="GHC plugin to do inspection testing"
+HOMEPAGE="https://github.com/nomeata/inspection-testing"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # examples/Fusion.hs:22:1: sumUp1 === sumUp2 failed
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ >=dev-lang/ghc-8.0.2:=[profile?] <dev-lang/ghc-8.11:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-more-tests
+}