summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r2.ebuild')
-rw-r--r--dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r2.ebuild b/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r2.ebuild
new file mode 100644
index 000000000000..286e3937405a
--- /dev/null
+++ b/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -check-bounds,+integer-gmp
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Integer logarithms"
+HOMEPAGE="https://github.com/haskellari/integer-logarithms"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/quickcheck-2.14.1 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/smallcheck-1.2 <dev-haskell/smallcheck-1.3
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds \
+ --flag=integer-gmp
+}
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}