summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/invariant/invariant-0.6.2.ebuild')
-rw-r--r--dev-haskell/invariant/invariant-0.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/invariant/invariant-0.6.2.ebuild b/dev-haskell/invariant/invariant-0.6.2.ebuild
new file mode 100644
index 000000000000..719a1d450ef1
--- /dev/null
+++ b/dev-haskell/invariant/invariant-0.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell98 invariant functors"
+HOMEPAGE="https://github.com/nfrisby/invariant-functors"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/bifunctors-5.2:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ >=dev-haskell/comonad-5:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/profunctors-5.2.1:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-2:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/th-abstraction-0.4:=[profile?] <dev-haskell/th-abstraction-0.7:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.4:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/hspec-1.8
+ >=dev-haskell/quickcheck-2.11 <dev-haskell/quickcheck-3 )
+"