summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/io-streams-haproxy/io-streams-haproxy-1.0.1.0-r1.ebuild')
-rw-r--r--dev-haskell/io-streams-haproxy/io-streams-haproxy-1.0.1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/io-streams-haproxy/io-streams-haproxy-1.0.1.0-r1.ebuild b/dev-haskell/io-streams-haproxy/io-streams-haproxy-1.0.1.0-r1.ebuild
new file mode 100644
index 000000000000..c4dab9cf9893
--- /dev/null
+++ b/dev-haskell/io-streams-haproxy/io-streams-haproxy-1.0.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HAProxy protocol 1.5 support for io-streams"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # two tests require network access
+
+RDEPEND=">=dev-haskell/attoparsec-0.7:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.6:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.13' 'base >= 4.5' \
+ 'network >= 2.3 && < 3.1' 'network >= 2.3 && < 3.2'
+}