summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/juicypixels/juicypixels-3.3.5.ebuild')
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.3.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild b/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild
new file mode 100644
index 000000000000..7a2fbfdee5af
--- /dev/null
+++ b/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="JuicyPixels"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Picture loading/serialization (in png, jpeg, bitmap, gif, tga, tiff and others)"
+HOMEPAGE="https://github.com/Twinside/Juicy.Pixels"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmap"
+
+RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/primitive-0.4:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/zlib-0.5.3.1:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mmap mmap)
+}