summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/juicypixels')
-rw-r--r--dev-haskell/juicypixels/Manifest1
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.3.5.ebuild10
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.3.7.ebuild37
-rw-r--r--dev-haskell/juicypixels/metadata.xml10
4 files changed, 49 insertions, 9 deletions
diff --git a/dev-haskell/juicypixels/Manifest b/dev-haskell/juicypixels/Manifest
index 9cfa62d570d3..5c7732637649 100644
--- a/dev-haskell/juicypixels/Manifest
+++ b/dev-haskell/juicypixels/Manifest
@@ -1 +1,2 @@
DIST JuicyPixels-3.3.5.tar.gz 131914 BLAKE2B a541f8052952e9a757fecb7168a74b9cb6aef152a1913aad36ac47d4ea2dbdeec9c644a0d2edf340986bd179ba4e925d3d284fbe73725e149e2b87866a8a5865 SHA512 40ce63d01fb4dea77caeb055cf2f9f16b32252c7c5ea501b93c9020e426da9ea019b6e618da373fa41bae93789b76561f2b091bfe9340ee9c75f4d8fe29f90ed
+DIST juicypixels-3.3.7.tar.gz 132469 BLAKE2B 06b58a9969b084eeb4bea2b4e88691d92d77ebdb30fdde944c90bd4b77f780d52dd3fa1f44e0415e71bfed29c5259ec65c434f04075f02935fe052236ac1f4b2 SHA512 adb3ccae12524ddb6f2736d65d14d997e1d672960b2fcc02739742fe18d748497324c9aeecb0b0b5e7662b218c5db55b2e8f5639e6438e0b8a45960c9c0e7da1
diff --git a/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild b/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild
index 7a2fbfdee5af..730b4ec64d54 100644
--- a/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild
+++ b/dev-haskell/juicypixels/juicypixels-3.3.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.4.9999
@@ -17,9 +17,13 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="mmap"
+CABAL_CHDEPS=(
+ 'bytestring >= 0.9 && < 0.11' 'bytestring >=0.9'
+)
+
RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/primitive-0.4:=[profile?]
>=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
diff --git a/dev-haskell/juicypixels/juicypixels-3.3.7.ebuild b/dev-haskell/juicypixels/juicypixels-3.3.7.ebuild
new file mode 100644
index 000000000000..217a2ad292c8
--- /dev/null
+++ b/dev-haskell/juicypixels/juicypixels-3.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.2.9999
+
+CABAL_PN="JuicyPixels"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Picture loading/serialization (in png, jpeg, bitmap, gif, tga, tiff and others)"
+HOMEPAGE="https://github.com/Twinside/Juicy.Pixels"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="mmap"
+
+RDEPEND=">=dev-haskell/primitive-0.4:=[profile?]
+ <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/zlib-0.5.3.1:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+CABAL_CHDEPS=(
+ 'mtl >= 1.1 && < 2.3' 'mtl >= 1.1'
+)
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mmap mmap)
+}
diff --git a/dev-haskell/juicypixels/metadata.xml b/dev-haskell/juicypixels/metadata.xml
index a1ef9357fe85..9bb364346e80 100644
--- a/dev-haskell/juicypixels/metadata.xml
+++ b/dev-haskell/juicypixels/metadata.xml
@@ -5,13 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- &lt;&lt;data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAMAAAADABAMAAACg8nE0AAAAElBMVEUAAABJqDSTWEL/qyb///8AAABH/1GTAAAAAXRSTlMAQObYZgAAAN5JREFUeF7s1sEJgFAQxFBbsAV72v5bEVYWPwT/XDxmCsi7zvHXavYREBDI3XP2GgICqBBYuwIC+/rVayPUAyAg0HvIXBcQoDFDGnUBgWQQ2Bx3AYFaRoBpAQHWb3bt2ARgGAiCYFFuwf3X5HA/McgGJWI2FdykCv4aBYzmKwDwvl6NVmUAAK2vlwEALK7fo88GANB6HQsAAAAAAAAA7P94AQCzswEAAAAAAAAAAAAAAAAAAICzh4UAO4zWAYBfRutHA4Bn5C69JhowAMGoBaMWDG0wCkbBKBgFo2AUAACPmegUST/IJAAAAABJRU5ErkJggg==&gt;&gt;
-
- This library can load and store images in PNG,Bitmap, Jpeg, Radiance and
- read Gif images.
- </longdescription>
+ <use>
+ <flag name="mmap">Enable the file loading via mmap (memory map)</flag>
+ </use>
<upstream>
+ <remote-id type="hackage">JuicyPixels</remote-id>
<remote-id type="github">Twinside/Juicy.Pixels</remote-id>
</upstream>
</pkgmetadata>