summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/libmpd/libmpd-0.10.0.0.ebuild')
-rw-r--r--dev-haskell/libmpd/libmpd-0.10.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/libmpd/libmpd-0.10.0.0.ebuild b/dev-haskell/libmpd/libmpd-0.10.0.0.ebuild
new file mode 100644
index 000000000000..499b2215af76
--- /dev/null
+++ b/dev-haskell/libmpd/libmpd-0.10.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.1.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An MPD client library"
+HOMEPAGE="https://github.com/vimus/libmpd-haskell#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'text >= 0.11 && < 2' 'text >= 0.11'
+)
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.1:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/data-default-class-0.0.1:=[profile?] <dev-haskell/data-default-class-1:=[profile?]
+ >=dev-haskell/network-2.6.3.5:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1:=[profile?] <dev-haskell/safe-exceptions-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3.1:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+ test? ( >=dev-haskell/hspec-2
+ >=dev-haskell/quickcheck-2.10 )
+"