summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/libyaml/libyaml-0.1.2.ebuild')
-rw-r--r--dev-haskell/libyaml/libyaml-0.1.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-haskell/libyaml/libyaml-0.1.2.ebuild b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
index 6bcbb87f5f82..3dfe12bbb09c 100644
--- a/dev-haskell/libyaml/libyaml-0.1.2.ebuild
+++ b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="no-unicode system-libyaml"
+IUSE="+unicode system-libyaml"
RDEPEND=">=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
>=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
@@ -27,7 +27,10 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ local unicode_flag="no-unicode"
+ use unicode && unicode_flag="-no-unicode"
+
haskell-cabal_src_configure \
- $(cabal_flag no-unicode no-unicode) \
+ --flag="${unicode_flag}" \
$(cabal_flag system-libyaml system-libyaml)
}