summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lifted-async/lifted-async-0.10.2.ebuild')
-rw-r--r--dev-haskell/lifted-async/lifted-async-0.10.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
new file mode 100644
index 000000000000..f90e56840529
--- /dev/null
+++ b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/maoe/lifted-async"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'base >= 4.5 && < 4.16' 'base >= 4.5'
+)
+
+RDEPEND=">=dev-haskell/async-2.2:=[profile?] <dev-haskell/async-2.3:=[profile?]
+ >=dev-haskell/constraints-0.2:=[profile?] <dev-haskell/constraints-0.14:=[profile?]
+ >=dev-haskell/lifted-base-0.2:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-9.0.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.4.1.0
+ test? ( dev-haskell/hunit
+ dev-haskell/tasty
+ <dev-haskell/tasty-expected-failure-0.13
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ dev-haskell/tasty-th )
+"