summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lukko')
-rw-r--r--dev-haskell/lukko/Manifest3
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.2.ebuild36
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.3-r1.ebuild41
-rw-r--r--dev-haskell/lukko/metadata.xml43
4 files changed, 47 insertions, 76 deletions
diff --git a/dev-haskell/lukko/Manifest b/dev-haskell/lukko/Manifest
index 4bd93cb9427f..7ae64b144fc0 100644
--- a/dev-haskell/lukko/Manifest
+++ b/dev-haskell/lukko/Manifest
@@ -1 +1,2 @@
-DIST lukko-0.1.1.2.tar.gz 28366 BLAKE2B 8e7a0257c187ed76f2399a2ca381210ad44d683faff74ca583658eab13545e6809fe6ea57b4c4c22c16560272c0d53736183437e4f5ad64919d98dbac239a864 SHA512 fe3a6687b741491ebaeace29c8d4d01307fad43f0e649c087fef24ec227eb231541fa1500e1685c814eb2a1ea472546033e837ce84fa64df79f00b19f8abebb6
+DIST lukko-0.1.1.3-rev4.cabal 4584 BLAKE2B f940efd241489c7a078f0c13edf2cd1cce1a6e99109cd423fedefd94ffe73a3a83b021b49c54a760e554f9c6f254261ed16f533feb262543acc5f40a8eba72b8 SHA512 5cde0f7dc7037037a42b73675e1d0c597f77190b5878f6246bc8c71f57fca6de8bb4fb87297fd6dfd145109354341bac55d822ee6c399edbd968f81be2b26a7b
+DIST lukko-0.1.1.3.tar.gz 28575 BLAKE2B 9f0006d05ba1db03de6fda88265e8949797201124f71ca6690113431f398eb59f19ec67363eb6b2834cac136e985b84882d45dfeb71c67e1147dd000c06cd243 SHA512 8bed8b88a101883f642bb9d9d41512436f5c80db5ea1ad0cddb069c6d09257d21b56a60e0f70b57453e91126065fbfdeeb721064763e64de1975dcb51b1a484a
diff --git a/dev-haskell/lukko/lukko-0.1.1.2.ebuild b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
deleted file mode 100644
index 6dcaf99f3e07..000000000000
--- a/dev-haskell/lukko/lukko-0.1.1.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="File locking"
-HOMEPAGE="https://hackage.haskell.org/package/lukko"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ofd-locking"
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2
- test? ( >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
- >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
- >=dev-haskell/tagged-0.8.5 <dev-haskell/tagged-0.9
- >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.3
- >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.12
- >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
- >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4 )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag ofd-locking ofd-locking)
-}
diff --git a/dev-haskell/lukko/lukko-0.1.1.3-r1.ebuild b/dev-haskell/lukko/lukko-0.1.1.3-r1.ebuild
new file mode 100644
index 000000000000..b89bdca78478
--- /dev/null
+++ b/dev-haskell/lukko/lukko-0.1.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +ofd-locking
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File locking"
+HOMEPAGE="https://hackage.haskell.org/package/lukko"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+ >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4
+ || (
+ ( >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.12 )
+ ( >=dev-haskell/tasty-expected-failure-0.12.2 <dev-haskell/tasty-expected-failure-0.13 )
+ )
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=ofd-locking
+}
diff --git a/dev-haskell/lukko/metadata.xml b/dev-haskell/lukko/metadata.xml
index 813bd62764bc..a6129181f6be 100644
--- a/dev-haskell/lukko/metadata.xml
+++ b/dev-haskell/lukko/metadata.xml
@@ -5,43 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="ofd-locking">Enable open file descriptor locking. Available on Linux (kernel 3.15, released Jun 8, 2014).</flag>
- </use>
- <longdescription>
- This package provides access to platform dependent file locking APIs:
-
- * Open file descriptor locking on Linux ("Lukko.OFD")
- * @flock@ locking on unix platforms ("Lukko.FLock")
- * Windows locking @LockFileEx@ ("Lukko.Windows")
- * No-op locking, which throws exceptions ("Lukko.NoOp")
- * "Lukko" module exports the best option for the target platform with uniform API.
-
- There are alternative file locking packages:
-
- * "GHC.IO.Handle.Lock" in @base &gt;= 4.10@ is good enough for most use cases.
- However, uses only 'Handle's so these locks cannot be used for intra-process locking.
- (You should use e.g. 'MVar' in addition).
-
- * &lt;https://hackage.haskell.org/package/filelock filelock&gt; doesn't support OFD locking.
-
- /Lukko/ means lock in Finnish.
-
- Submodules "Lukko.OFD", "Lukko.Windows" etc are available based on following conditions.
-
- @
- if os(windows)
- \ cpp-options: -DHAS_WINDOWS_LOCK
-
- elif (os(linux) &amp;&amp; flag(ofd-locking))
- \ cpp-options: -DHAS_OFD_LOCKING
- \ cpp-options: -DHAS_FLOCK
-
- elif !(os(solaris) || os(aix))
- \ cpp-options: -DHAS_FLOCK
- @
-
- "Lukko.FLock" is available on not (Windows or Solaris or AIX).
- "Lukko.NoOp" is always available.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">lukko</remote-id>
+ <remote-id type="github">haskellari/lukko</remote-id>
+ </upstream>
</pkgmetadata>