summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/microstache/microstache-1.0.2.ebuild')
-rw-r--r--dev-haskell/microstache/microstache-1.0.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/microstache/microstache-1.0.2.ebuild b/dev-haskell/microstache/microstache-1.0.2.ebuild
new file mode 100644
index 000000000000..9e5d938cee2c
--- /dev/null
+++ b/dev-haskell/microstache/microstache-1.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="3"
+inherit haskell-cabal
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="Mustache templates for Haskell"
+HOMEPAGE="https://github.com/haskellari/microstache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?] <dev-haskell/aeson-2.1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/aeson
+ >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}