summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-control/monad-control-0.2.0.3.ebuild')
-rw-r--r--dev-haskell/monad-control/monad-control-0.2.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild b/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild
new file mode 100644
index 000000000000..d8482e41bbfd
--- /dev/null
+++ b/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Lift control operations, like exception catching, through monad transformers"
+HOMEPAGE="https://github.com/basvandijk/monad-control/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="<dev-haskell/base-unicode-symbols-0.3
+ =dev-haskell/transformers-0.2*
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? (
+ >=dev-haskell/cabal-1.10
+ <dev-haskell/test-framework-0.5
+ <dev-haskell/test-framework-hunit-0.3
+ )
+ "
+
+src_configure() {
+ cabal_src_configure $(use_enable test tests) $(cabal_flag test)
+}