summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-control/monad-control-0.3.2.ebuild')
-rw-r--r--dev-haskell/monad-control/monad-control-0.3.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/monad-control/monad-control-0.3.2.ebuild b/dev-haskell/monad-control/monad-control-0.3.2.ebuild
new file mode 100644
index 000000000000..e3c873f33c19
--- /dev/null
+++ b/dev-haskell/monad-control/monad-control-0.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Lift control operations, like exception catching, through monad transformers"
+HOMEPAGE="https://github.com/basvandijk/monad-control"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="+instancest"
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1:=[profile?]
+ <dev-haskell/base-unicode-symbols-0.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?]
+ <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 3 && < 4.7' 'base >= 3 && < 5.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag instancest instancest)
+}