summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/nanospec/nanospec-0.2.2.ebuild')
-rw-r--r--dev-haskell/nanospec/nanospec-0.2.2.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/dev-haskell/nanospec/nanospec-0.2.2.ebuild b/dev-haskell/nanospec/nanospec-0.2.2.ebuild
index 126fa7b9a6ce..c14d160d5dfb 100644
--- a/dev-haskell/nanospec/nanospec-0.2.2.ebuild
+++ b/dev-haskell/nanospec/nanospec-0.2.2.ebuild
@@ -1,26 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# ebuild generated by hackport 0.5.5.9999
+# ebuild generated by hackport 0.8.0.0.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # drop test-suite: cyclic depend
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="A lightweight implementation of a subset of Hspec's API"
HOMEPAGE="https://github.com/hspec/nanospec#readme"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-RESTRICT=test # cyclic depend: silently[test]->nanospec
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/silently-1.2.4
+ )
"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}