summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/network/network-3.1.3.0.ebuild')
-rw-r--r--dev-haskell/network/network-3.1.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/network/network-3.1.3.0.ebuild b/dev-haskell/network/network-3.1.3.0.ebuild
new file mode 100644
index 000000000000..caff0339fd4c
--- /dev/null
+++ b/dev-haskell/network/network-3.1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level networking interface"
+HOMEPAGE="https://github.com/haskell/network"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="devel"
+
+RDEPEND=">=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/hspec-2.6
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag devel devel)
+}