summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/onetuple/onetuple-0.4.1.1.ebuild')
-rw-r--r--dev-haskell/onetuple/onetuple-0.4.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/onetuple/onetuple-0.4.1.1.ebuild b/dev-haskell/onetuple/onetuple-0.4.1.1.ebuild
new file mode 100644
index 000000000000..cdbeb54747e4
--- /dev/null
+++ b/dev-haskell/onetuple/onetuple-0.4.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_PN="OneTuple"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Singleton Tuple"
+HOMEPAGE="https://hackage.haskell.org/package/OneTuple"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/base-orphans-0.8.6:=[profile?]
+ >=dev-haskell/foldable1-classes-compat-0.1:=[profile?] <dev-haskell/foldable1-classes-compat-0.2:=[profile?]
+ >=dev-haskell/hashable-1.3.5.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"