summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/opengl/opengl-2.5.0.0.ebuild')
-rw-r--r--dev-haskell/opengl/opengl-2.5.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/opengl/opengl-2.5.0.0.ebuild b/dev-haskell/opengl/opengl-2.5.0.0.ebuild
new file mode 100644
index 000000000000..52b855fb1d5a
--- /dev/null
+++ b/dev-haskell/opengl/opengl-2.5.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="OpenGL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/gluraw-1.1.0.0[profile?]
+ =dev-haskell/objectname-1.0*[profile?]
+ >=dev-haskell/openglraw-1.1.0.0[profile?]
+ =dev-haskell/statevar-1.0*[profile?]
+ =dev-haskell/tensor-1.0*[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"