summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/options')
-rw-r--r--dev-haskell/options/Manifest1
-rw-r--r--dev-haskell/options/metadata.xml59
-rw-r--r--dev-haskell/options/options-1.2.1.1.ebuild6
-rw-r--r--dev-haskell/options/options-1.2.1.2.ebuild32
4 files changed, 40 insertions, 58 deletions
diff --git a/dev-haskell/options/Manifest b/dev-haskell/options/Manifest
index c7c54738adab..53b51528f0b1 100644
--- a/dev-haskell/options/Manifest
+++ b/dev-haskell/options/Manifest
@@ -1 +1,2 @@
DIST options-1.2.1.1.tar.gz 25327 BLAKE2B 66611694e5beb558e185cd9a89e9368ebac035118360a4c1cb9bcba5ad2a0be74c32848e3983aec999b4cee6e3138c527fe31c869b52c84719ee89afe3aad232 SHA512 615a3767b74ca0ba2eae993f6e475963df2a0933f1e6c9bbfe35144c4dc6018af276144b2ec1b608b695dc7fca904784ebc63cd58a432f966588846cb36f94ea
+DIST options-1.2.1.2.tar.gz 22693 BLAKE2B 4e17e038a910deb114182a5f98860cf4bef6ee6b03901105a23760cd108352e5be63ba762dadbd225ec10ef7c3b34c76184ccc927a36f2ff4720d6c0ee77ae5f SHA512 82c366adce56a27ab68a4388bc759b90ee4bfe38fd72325af954bef2eb3aee360729d5ed2de2964c8087b3b5a51d321321d9c02024b34b6167f09d7412aa2568
diff --git a/dev-haskell/options/metadata.xml b/dev-haskell/options/metadata.xml
index 284861e4945d..c78c1cd7c4aa 100644
--- a/dev-haskell/options/metadata.xml
+++ b/dev-haskell/options/metadata.xml
@@ -5,59 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @options@ package lets library and application developers easily work
- with command-line options.
-
- The following example is a full program that can accept two options,
- @--message@ and @--quiet@:
-
- @
- import Control.Applicative
- import Options
-
- data MainOptions = MainOptions
- &amp;#x20; &amp;#x7b; optMessage :: String
- &amp;#x20; , optQuiet :: Bool
- &amp;#x20; &amp;#x7d;
-
- instance 'Options' MainOptions where
- &amp;#x20; defineOptions = pure MainOptions
- &amp;#x20; \&lt;*\&gt; simpleOption \"message\" \"Hello world!\"
- &amp;#x20; \"A message to show the user.\"
- &amp;#x20; \&lt;*\&gt; simpleOption \"quiet\" False
- &amp;#x20; \"Whether to be quiet.\"
-
- main :: IO ()
- main = runCommand $ \\opts args -&gt; do
- &amp;#x20; if optQuiet opts
- &amp;#x20; then return ()
- &amp;#x20; else putStrLn (optMessage opts)
- @
-
- &gt;$ ./hello
- &gt;Hello world!
- &gt;$ ./hello --message='ciao mondo'
- &gt;ciao mondo
- &gt;$ ./hello --quiet
- &gt;$
-
- In addition, this library will automatically create documentation options
- such as @--help@ and @--help-all@:
-
- &gt;$ ./hello --help
- &gt;Help Options:
- &gt; -h, --help
- &gt; Show option summary.
- &gt; --help-all
- &gt; Show all help options.
- &gt;
- &gt;Application Options:
- &gt; --message :: text
- &gt; A message to show the user.
- &gt; default: "Hello world!"
- &gt; --quiet :: bool
- &gt; Whether to be quiet.
- &gt; default: false
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">options</remote-id>
+ <remote-id type="github">typeclasses/options</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/options/options-1.2.1.1.ebuild b/dev-haskell/options/options-1.2.1.1.ebuild
index a6d4c06bbb96..410373f86de7 100644
--- a/dev-haskell/options/options-1.2.1.1.ebuild
+++ b/dev-haskell/options/options-1.2.1.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.4.4.9999
@@ -14,7 +14,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RESTRICT=test # circular depends: options[test]->chell->options
diff --git a/dev-haskell/options/options-1.2.1.2.ebuild b/dev-haskell/options/options-1.2.1.2.ebuild
new file mode 100644
index 000000000000..f8c85444f9d0
--- /dev/null
+++ b/dev-haskell/options/options-1.2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Powerful and easy command-line option parser"
+HOMEPAGE="https://github.com/typeclasses/options/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'base ^>= 4.16 || ^>= 4.17 || ^>= 4.18' 'base >= 4.14 && < 5'
+)
+
+RDEPEND="
+ >=dev-haskell/monads-tf-0.3:=[profile?] <dev-haskell/monads-tf-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hspec-2.9.7 <dev-haskell/hspec-2.12
+ >=dev-haskell/patience-0.3 <dev-haskell/patience-0.4
+ )
+"