summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild')
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
deleted file mode 100644
index d56932e09dbb..000000000000
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Supports using pandoc with citeproc"
-HOMEPAGE="https://hackage.haskell.org/package/pandoc-citeproc"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed-data-files +hexpat +network +small-base unicode_collation"
-RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
-
-RDEPEND=">=app-text/pandoc-1.12.0.2:=[profile?]
- dev-haskell/aeson:=[profile?]
- dev-haskell/attoparsec:=[profile?]
- dev-haskell/json:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pandoc-types-1.12.3:=[profile?]
- dev-haskell/parsec:=[profile?]
- dev-haskell/split:=[profile?]
- dev-haskell/syb:=[profile?]
- dev-haskell/tagsoup:=[profile?]
- >=dev-haskell/texmath-0.6.4:=[profile?]
- dev-haskell/text:=[profile?]
- dev-haskell/utf8-string:=[profile?]
- dev-haskell/vector:=[profile?]
- >=dev-haskell/yaml-0.8:=[profile?]
- >=dev-lang/ghc-6.12.1:=
- bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
- hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
- !hexpat? ( dev-haskell/xml:=[profile?] )
- network? ( >=dev-haskell/http-4000.0.9:=[profile?]
- >=dev-haskell/network-2:=[profile?] )
- unicode_collation? ( dev-haskell/text-icu:=[profile?] )
- !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.12
- test? ( dev-haskell/aeson-pretty
- >=dev-haskell/diff-0.3 )
-"
-
-src_configure() {
- # workaround bug on ghc-7.6.3:
- # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
- # > stack overflow: use +RTS -K<size> to increase it
- replace-hcflags -O[2-9] -O1
-
- haskell-cabal_src_configure \
- $(cabal_flag bibutils bibutils) \
- $(cabal_flag embed-data-files embed_data_files) \
- $(cabal_flag hexpat hexpat) \
- $(cabal_flag network network) \
- $(cabal_flag small-base small_base) \
- $(cabal_flag unicode_collation unicode_collation)
-}