summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/pango/pango-0.13.10.0.ebuild')
-rw-r--r--dev-haskell/pango/pango-0.13.10.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/pango/pango-0.13.10.0.ebuild b/dev-haskell/pango/pango-0.13.10.0.ebuild
new file mode 100644
index 000000000000..1beb5cff52e8
--- /dev/null
+++ b/dev-haskell/pango/pango-0.13.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Pango text rendering engine"
+HOMEPAGE="https://projects.haskell.org/gtk2hs/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-3.11
+"
+BDEPEND="virtual/pkgconfig
+ >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+"
+
+GHC_BOOTSTRAP_PACKAGES=( gtk2hs-buildtools )