summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild')
-rw-r--r--dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild b/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild
new file mode 100644
index 000000000000..e31e8cee36c8
--- /dev/null
+++ b/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite circular depends
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic parser combinators"
+HOMEPAGE="https://github.com/haskell/parsec"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
+
+RDEPEND="
+ >=dev-lang/ghc-9.2.4:=
+"
+DEPEND="${RDEPEND}
+"
+# test? (
+# >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+# )
+
+CABAL_CORE_LIB_GHC_PV="9.2.4 9.2.5 9.2.6 9.2.7 9.2.8 9.4.4 9.4.5"