summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/persistent')
-rw-r--r--dev-haskell/persistent/Manifest1
-rw-r--r--dev-haskell/persistent/persistent-2.10.5.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/persistent/Manifest b/dev-haskell/persistent/Manifest
index 4e47882ee140..10285fc1bfff 100644
--- a/dev-haskell/persistent/Manifest
+++ b/dev-haskell/persistent/Manifest
@@ -1,2 +1,3 @@
DIST persistent-2.1.6.tar.gz 42889 BLAKE2B 73b5235cca8104b4d10cb87f8ec3faea4f4b4c48b017b5b6a44fbf50cd955b9446e6fccc91a1a7572f9e480270436723316e1c4ed25a8ee9b5399390ff4d8757 SHA512 b1de69547d252a142bce18b837b37be60cc384172473f08dc0d7826dc82f7ce879bb7e0860d31e5c8dadab78992f2c84766bdc804f6ca06b29fa5e7f8391273e
+DIST persistent-2.10.5.2.tar.gz 72570 BLAKE2B fb5fe4704076e66b6aa24615e4faa14803879b18da6dc972f7f05a5ecc27435ee4e7f46376a2082bb327b189db4cc51aa04f673ffc8df46d8b85a56e2c26b111 SHA512 5d7fe9259d89ab210bd136d9f9b0f3e52d48825a003cc02dfb01f50457324daf2c8659b9123cc0e958b636613fa61004f649f97980c6a5427d425656ceb166f1
DIST persistent-2.6.tar.gz 50030 BLAKE2B 434b452c55339acf3ebc5631d6038b1e875959b7b867f033d2d55b72a2cbcc536c999e25bfc1ee6326f93e2c3a730c8a9a781c4677a44a55648edd32951db6ac SHA512 39fe1ec0c959ca0ec9c37feda8b2e4d4ddd706ae2bd4de9c4161db02c85747475f5a61d5daa3ef73f4adc061e13ff138edcbe34fe1baeb93512c1fe68053a282
diff --git a/dev-haskell/persistent/persistent-2.10.5.2.ebuild b/dev-haskell/persistent/persistent-2.10.5.2.ebuild
new file mode 100644
index 000000000000..1bbbd221307b
--- /dev/null
+++ b/dev-haskell/persistent/persistent-2.10.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type-safe, multi-backend data serialization"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="nooverlap"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.9:=[profile?]
+ >=dev-haskell/conduit-1.2.12:=[profile?]
+ >=dev-haskell/fast-logger-2.4:=[profile?]
+ >=dev-haskell/http-api-data-0.3:=[profile?]
+ >=dev-haskell/monad-logger-0.3.28:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/path-pieces-0.2:=[profile?]
+ >=dev-haskell/resource-pool-0.2.3:=[profile?]
+ >=dev-haskell/resourcet-1.1.10:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/silently:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/hspec-2.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag nooverlap nooverlap)
+}