summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.14.2.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.14.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.14.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.14.2.ebuild
new file mode 100644
index 000000000000..ab6efc03e6ab
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.14.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +base4,-base3,-old-random,templatehaskell:template-haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+template-haskell"
+
+RDEPEND=">=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ >=dev-haskell/random-1.2.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ --flag=-old-random \
+ $(cabal_flag template-haskell templatehaskell)
+}